live-chat may be slow or unresponsive
Incident Report for Passthrough
Resolved
This incident has been resolved.
Posted Jul 28, 2023 - 01:58 UTC
Investigating
Our live-chat vendor is experiencing a disruption in service. For immediate assistance please contact support@passthrough.com.

Our vendor's status page can be found here: https://status.kustomer.com/incidents/ynpzl8z0r8wc
Posted Jul 27, 2023 - 16:53 UTC
This incident affected: app.passthrough.com and sandbox.passthrough.com.