DocuSign outage

Incident Report for Passthrough

Resolved

DocuSign has reported that the incident has been resolved.
Posted Jul 18, 2025 - 19:58 UTC

Update

We are continuing to investigate this issue.
Posted Jul 18, 2025 - 19:35 UTC

Update

DocuSign appears to have fixed the issue. We will continue to monitor
Posted Jul 18, 2025 - 19:31 UTC

Update

We are continuing to investigate this issue.
Posted Jul 18, 2025 - 19:27 UTC

Investigating

Our upstream signing provider, DocuSign, is experiencing issues. Users ability to sign documents may be impacted.

See https://status.docusign.com/
Posted Jul 18, 2025 - 19:17 UTC
This incident affected: app.passthrough.com.