Kustomer chat issue
Incident Report for Passthrough
Resolved
This incident has been resolved.
Posted Aug 16, 2023 - 16:20 UTC
Investigating
We're investigating an issue with in-app chat. Contact support@passthrough.com for immediate assistance.
Posted Aug 16, 2023 - 14:26 UTC
This incident affected: app.passthrough.com.