Docusign disruption
Incident Report for Passthrough
Resolved
This incident has been resolved.
Posted Sep 12, 2023 - 20:39 UTC
Identified
Docusign is experiencing a disruption in service and may be slow to load. For immediate assistance please contact support@passthrough.com. See the following page for more details https://status.docusign.com/incidents/wv0565kpwx2n
Posted Sep 12, 2023 - 19:41 UTC
This incident affected: app.passthrough.com and sandbox.passthrough.com.